IHP 1.0 is out now!
Create a new thread +
Nix error when using IHP on Mac M1
Adam Harris
Hi, I'm trying to get up and running on a mac M1. I've followed the steps here: https://ihp.digitallyinduced.com/Guide/installation.html to install nix and IHP - everything seemed to work without issues. However when I try and run …
Add Response
Running IHP on M1/M2 Mac
Hi How to enable caching on M1 Mac? Right now, it compiles everything from scratch …
Add Response
Running IHP as a systemd service on NixOS
Lillo PRO
Hi! This might be mostly systemd related, but I'm trying to run IHP as a systemd service on a NixOS webserver, eventually on DigitalOcean for a service I am making. Currently testing locally on my NixOS machine with a fresh IHP project.…
Add Response
How do I see my application specific code in ghci?
when I run ghci in nix-shell I can see all the IHP.Prelude code but I can't see any of the code in my current application. How do I interact with my own code in ghci? Trying things in a repl is one of the main reasons why I like Haskell…
Add Response
how do you run ghci in the IHP context?
I am trying to run ghci on my terminal but it can't see the libraries, what is the syntax to run ghci? Here is the output I get from just running ghci: ghci GHCi, version 8.10.1: https://www.haskell.org/ghc/ :? for help Loaded package…
Add Response
#IDK Issue while installing IHP on kali linux
I've been trying to install IHP on Kali Linux (using official docs ofc), but when i came to "nix-env -f https://ihp.digitallyinduced.com/ihp-new.tar.gz -i ihp-new" and ran it that happened: "syntax error, unexpected end o…
Add Response
Finding compatible libraries/versions with Nix
I'm usually a Stack user who doesn't bother with version bounds or anything like that for personal projects, so I'm used to adding a package to my dependencies and simply letting Stack figure our how to make it work. I tried to …
Add Response