IHP 1.1 is out now!

Problems With Deploying to IHPCloud

Willy Unterkoefler

The last three attempts to deploy my project (https://github.com/unterkoefler/xcuseme) to IHPCloud failed with several different errors.

First, for this commit one week ago there was this error when auto-deploying:

RecordNotFoundException {queryAndParams = ("SELECT containers.id, containers.status, containers.is_used, containers.created_at, containers.ip_address, containers.name, containers.project_id, containers.cpu_usage, containers.memory_usage, containers.network_usage, containers.host, containers.docker_container_id, containers.docker_host_port, containers.app_type FROM containers WHERE containers.id = ?",[Plain "'<CONTAINER_ID>'"])}

Today, I tried upgrading from v0.19.0 to v1.0.0 to see if that might resolve the issue, but it failed with the same error, this time with a different container id. Next, I clicked "Restart App" from the Settings page, which seemed to complete successfully. After that, I deployed manually from the Overview page. This failed with the following error:

Failed to find port CallStack (from HasCallStack): error, called at ./IHP/Prelude.hs:89:17 in ihp-0.18.0-DOm7A8EdwdyE2tivA3ymnA:IHP.Prelude

I'm somewhat suspicious of the reference to ihp-0.18.0 in that error message.

Also, at some point today (possibly after restarting), my site began 502ing.

Thanks in advance!

Joachim Breitner

I regularly run into the first issue when deploying form git, and for me it always works when do the manual deploy. Can’t help you with the second, though.

marc PRO

The build infrastructure is a bit unstable at the moment. The runtime system is not affected by this, so deployed apps run stable.

The 0.18.0 error message is because IHP Cloud itself is running on ihp v0.18.0