Hot reload port specification

zhan ishzhanov

Im running ihp in gitpod.io and the localhost gets proxied, so hot reload stops working. I belief the common solution to this is letting users specify hmr port. Ideally the front-end side would just modify the localhost part itself if it determines it's not running on localhost, because that part gets changed when new subdomain gets assigned to the machine.

marc PRO

Agree, i think there's been a github issue on this in the past.

Is your project open on GitHub? Then I'd give it a try on gitpod and maybe apply necessary changes

zhan ishzhanov

gitpod.io/#https://github.com/janat08/ihp-blog I played around with it some more to make it more acceptable towards to providing a link on the github repo for other users to try ihp. I didn't get around the nested directory for project within nix-template repo, and I don't run ihp-new on docker initialization.

needs to be changed: .vscode/settings.json.nixEnvSelector.nixFile ide goto env isn't set, or hsx extension

zhan ishzhanov

It got really finnicky after playing with gitpod.yml it seems. The cachix would not be used. It could also be envrc as there're two of those now.

zhan ishzhanov

After you restart the machine it gets broken, does a lot of compilation on ./start.

zhan ishzhanov

I'm getting my computer fixed but with GitHub codespaces having functioning cloud ide template would be trendy.

marc PRO

I've created https://github.com/digitallyinduced/ihp-gitpod-template When you create a pod based on that repo it should work. But there's still errors because IHP uses localhost everywhere. I'll try to get this fixed soon.

marc PRO

It's now all fixed and working :)

Give it a try:

Open in Gitpod

https://gitpod.io/#https://github.com/digitallyinduced/ihp-gitpod-template

zhan ishzhanov

It doesn't work for me, changing welcome page requires refresh. I searched localhost on github and it crops up like in 13 places.